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The object recognition technology from the ART tool enables you to auto-generate new hands-on simulation 
based exercises, demonstrations and step-by-step documentation simply by walking through a windows or 
web based application with the ART recorder tool activated.  

With ART you can customize the existing out of the box pre-built expert course content from Micro Focus and  
also enables you to create new content for both Micro Focus and Non-Micro Focus software applications.  

With the WYSIWYG Editor you can rapidly create and maintain step-by-step process documents and online 
courses with Multimedia content, Show-Me and Try-Me simulations and assessments. Track Compliance by 
exporting content as SCORM files for upload into your Learning Management System (LMS).   

 

ART Product homepage 
www.microfocus.com/en-us/education/art  
 
ART LMS Course Content Pack Samples  
for customer Learning Management System  
www.microfocus.com/software/artsamples 

Online Technical ART Support 
www.microfocus.com/software/art/art54/onlinesupport 
 
ART Documentation 
www.microfocus.com/documentation/ART/  
 
Micro Focus Education website 
www.microfocus.com/training    
Click here for Learning paths and Certifications 
Education Local contacts  
 

YouTube 
ART playlist – Youtube 
Join the Software Education Channel on 
YouTube  
 

 

 

 

 

 

https://www.microfocus.com/en-us/education/art
http://www.microfocus.com/software/artsamples
http://www.microfocus.com/software/art/art54/onlinesupport
https://www.microfocus.com/documentation/ART/
http://www.microfocus.com/training
https://inter.viewcentral.com/events/uploads/microfocus/certifications.html
https://microfocus.viewcentral.com/events/uploads/microfocus/contact.html
https://www.youtube.com/playlist?list=PL92KZZ3tyNdME1Gs4AHsL4nzQRqbzU7A0
https://www.youtube.com/playlist?list=PL92KZZ3tyNdME1Gs4AHsL4nzQRqbzU7A0
https://www.youtube.com/channel/UCyIyzdlQ8TqfbEZCIwWJU3w
https://www.youtube.com/channel/UCyIyzdlQ8TqfbEZCIwWJU3w
https://www.youtube.com/channel/UCyIyzdlQ8TqfbEZCIwWJU3w
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1 Introduction  

The Adoption Readiness Tool 5.40 Developer’s Kit (ART) is a standalone developer kit for creating training 

and enablement materials.  This document contains the steps necessary to install the Adoption Readiness 

Tool – ART together with the latest Micro Focus ART Template and ART Course Skin. 

Are you new to ART? Take the Free online training: Get Started with ART which can be launched directly 
from our Product Homepage www.microfocus.com/en-us/education/art 
The online course covers: 

• Installing ART and the post-installation steps 

• Record a step-by-step process and enhance it in the Editor 

• Publish a recording as a Show-Me, Try-Me simulation based exercise and other outputs 

• Create a training course, include pages, videos, simulations and an assessment  
 
 
How to publish and distribute your ART learning materials: 

1. Publish locally and transfer the published files to your target server/sharepoint/shared drive/etc. 
Publishing a local website support portal is only possible with the standard ART developer kit, not 
with the ART ELE Developer Kit. Samples of such a local websites published can be found on our 
samples site: www.microfocus.com/software/artsamples 
 

2. Publish the content locally and use the generated SCORM or AICC files to upload it into your own 
Learning Management System (LMS). The Micro Focus ART template is pre-configured to publish 
SCORM files and this can be changed through the template into AICC file format. 
 

3. Publish ART simulations as an MP4 video’s including voice narration or Text To Speech  
and upload it to your own video library, embed the video in your ART courses or upload the video to 
your own YouTube channel.  We have various free webinars you can follow to learn more. 
 

4. Use the hosted ART ELE Cloud portal which comes along with an integrated centralized version 
controlled repository and integrated webserver for one-click publishing of all content providing role-
based access for the learners. More information about ART ELE can be found on our product page 
www.microfocus.com/en-us/education/art 
 

 

  

https://www.microfocus.com/en-us/education/art
http://www.microfocus.com/software/artsamples
https://www.microfocus.com/en-us/education/art
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ART Webinars 

We recently delivered a series of free Expert ART Webinars to help you gain more in-depth knowledge of 

ART and learn directly from our ART experts.  

Watch the Webinar 

Boosting User Adoption  

with ART  

In this webinar for new customers, you will learn about: 

Effective on-boarding with simulation-based training; Auto-

Generate simulations, videos, JobAids and runbooks;  In-

Application Context Sensitive Help (CSH) for direct guidance; 

Customer Success Stories. If you prefer to join a live session, 

you can register your seat here. 

Watch Webinar 1 

Create a Product  

Demonstration Video 

In this webinar for existing ART customers, we’ll use ART to 

Auto-Generate a Product Demonstration video, include voice 

narrations and a powerpoint slide. Our subject matter expert 

will share tips and tricks and will show how to add this video 

together with a Try-Me simulation into an ART Course 

module.  

Watch Webinar 2  

Create an  

Online Course 

In this webinar for existing ART customers, we’ll use the ART 

editor to create an online course with multimedia content. 

Our expert will demonstrate how to add step-by-step 

simulation-based exercises, MP4 video files, YouTube movies, 

images, and documents to the downloads section of your 

course. 

Watch Webinar 3  

Create an  

Assessment Module  

In this webinar for existing ART customers, we’ll demonstrate 

how to use the ART course editor to include knowledge 

checks and an assessment module in your course. You’ll learn 

how to add various types of questions into the assessment 

and add simulations as Test-Me into the assessment. We’ll 

also show you how to configure and generate the SCORM file, 

so that you can upload it to your Learning Management 

System and do full tracking and tracing on who passed the 

assessment. 

Watch Webinar 4  

Create a Process 

Runbook  

In this webinar for existing ART customers, we’ll show you 

how to create a very detailed business process using 

Runbook. Our expert will publish several ART simulations to a 

web server and include the URLs into the Runbook. The 

Runbook itself is maintained in MS Word. Micro Focus 

Professional Services is using this technology to create their 

own Runbooks to document complex, internal administrative 

procedures. We’ll show you an example of what they have 

done.  

 

https://attendee.gotowebinar.com/register/8253210664747711499
https://attendee.gotowebinar.com/register/8253210664747711499
https://attendee.gotowebinar.com/register/8253210664747711499
https://register.gotowebinar.com/rt/3806622908530101251
https://attendee.gotowebinar.com/register/6283066147641163024
https://attendee.gotowebinar.com/register/6283066147641163024
https://attendee.gotowebinar.com/register/6283066147641163024
https://attendee.gotowebinar.com/register/8336886798118285071
https://attendee.gotowebinar.com/register/8336886798118285071
https://attendee.gotowebinar.com/register/8336886798118285071
https://attendee.gotowebinar.com/register/5557619370751749647
https://attendee.gotowebinar.com/register/5557619370751749647
https://attendee.gotowebinar.com/register/5557619370751749647
https://attendee.gotowebinar.com/register/7685487731330321932
https://attendee.gotowebinar.com/register/7685487731330321932
https://attendee.gotowebinar.com/register/7685487731330321932
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2 Installation Adoption Readiness Tool 

2.1 Backup before you install the software 

 

When you have been installing and using a previous version of ART on your PC, please be aware of 

the following: 

A. Any existing ART source files you will open with the new ART 5.40.8 software, will 
automatically be upgraded to ART 5.40.8 file format and can’t be opened anymore with the 
previous version. We recommend you to back-up your ART source files before you start 
editing them with the new ART software. 
 

B. If you are have been creating and using a fully customized template with an older ART 
software to reflect your company’s font’s, logo’s and colors in the published content,  you 
must export and back-up your template and skin before upgrading and installing the new 
ART software. Use the following steps to back-up your customized template and skin: 
1. Start ART and launch the Editor 

2. Select File>Preferences 

3. Select Manage Local Templates from the left menu 

 

4. Click the Export button and save the current customized template to folder where you 

want to save your current ART files, customized template and skin. 

5. Select Manage Local Custom Skins from the left menu  

6. Click the Export button and save the current customized skin to a folder where you want 

to save your current ART files, customized template and skin. 

7. Close the Editor 

8. Close ART 
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2.2 Uninstall your current ART software and remove the Roaming Data 
The next steps will describe how you should remove the current ART software and corresponding roaming 

data files. 

  

1. Uninstall the ART software through the windows configuration panel: Uninstall a 

program 

 
 

 

2. Uninstall the Capture Engine (if you have installed it earlier) through the windows 
configuration panel 
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3. Open the windows file explorer  

 
 

4. Navigate to folder  
C:\Users\<your name>\AppData\Roaming\Hewlett Packard Enterprise 
C:\Users\<your name>\AppData\Roaming\Micro Focus 
and remove any Adoption Readiness Tool (ART) related folders. If you installed both ART 
and ART ELE ensure to remove both folders from the roaming data folder. 
 

5. Navigate to folder C:\Users\<your name>\AppData\Roaming\  
and remove the Ancile folder  
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2.3 Reboot your PC 
Ensure to reboot your PC before you continue the next steps of installing the software.  

2.4 Install the ART Software 

The basic installation consists of the following steps: 

1. Run the ART installer and additional patch   

2. Run the ART Capture Engine installer  

3. Import the ART Template  

4. Import the ART Course Skin  

5. Set the ART Editor preferences 
 
 

After the import the skin is located physically under the roaming data folder:  
C:\users\<your name>\AppData\Roaming\Micro Focus\Adoption Readiness 

Tool\version 5.40\Skins\Course\Custom 
 

After the import the template is located physically under the roaming data folder:  
C:\users\<your name>\AppData\Roaming\Micro Focus\Adoption Readiness Tool\version 

5.40 \Templates 
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2.5 Recording on SilkCentral application  
In case you are recording on SilkCentral, you need to include the SilkCentral profile: 

1. Navigate to folder: Step 2 Capture Engine installation 
2. Select the MicroFocus Silk Central_19.cea  file and download it via the menu on the upper right 

corner 
3. Before continuing, ensure you are not recording and the ART application is closed. 
4. Paste the .CEA file into folder: 

c: \users\<your name>\appdata\Roaming\ANCILE\CaptureEngine\<version>\configuration\Data\Settings\CEA\ANCILE 
5. Start a new recording and use Internet Explorer.  

Now the data from the .cea file will be imported into the capture engine and is used during 
recording to optimize the recording actions. 
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2.6 Unzip the local help files 

The following steps describe how to install the local help files on your PC. 

1. Unzip the file  ART5.40.2Help.zip  that you can find in the installation folder 
Step 4 LocalHelpFiles Installation  

2. Navigate to the root of the unzipped help files and select the index.html file.  

3. Open this file with the Internet Explorer  

4. Add this page to your Internet Explorer favorites. 
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2.7 Windows7 PC and record voice narrations - Install LAME to generate MP3 
With ART you can record your voice to the steps in your step-by-step ART recordings and to the pages in 

your ART course files. By default on a Windows 10 PC, ART will record this in MP3 files and can be played 

natively by your browser. However if you use an older Windows 7 PC the voice narration files will be 

generated by ART in WMV file format which requires Flash to play them and that is not being supported 

anymore by most browsers. To avoid this problem we recommend you configure ART to produce MP3 sound 

files using the LAME encoder. In the following section is described how to copy the LAME encoder files to the 

ART bin folder to ensure that ART will produce MP3 sound files for the recording sound/voice narrations in 

ART.  

1. Stop the ART Editor 

2. Open the Internet Explorer  

3. Search for downloading the lame.exe and lame_enc.dll. 

4. You will find for example sites like: 

https://www.giga.de/downloads/lame/ 

From where you can download the 64bits version from Windows that contains both the lame.exe 

and lame_enc.dll. Note: You can also copy the two lame files from the step 4 folder of the ART 

installation you downloaded from the ART FTP 

5. A zip file will be downloaded to your PC 

6. Unzip the zip file and you will see the two main files 

lame.exe and LAME_ENC.DLL 

 

7. Select and copy both lame.exe and LAME_ENC.DLL  

 

8. Navigate to the folder:  

C:/Program Files (x86)/Adoption Readiness Tool/Client/bin 

and paste both LAME files into the bin directory. 

9. If the ART Editor is running, restart the Editor for the changes to take effect. 

Note: Once you have installed LAME, all voice recordings you will do with ART will be encoded as MP3 files. 

To be able to playback sound correctly in the show-me version of your locally published simulation you need 

to configure flash on your PC which is described in one of the previous installation steps.  

  

https://www.giga.de/downloads/lame/
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2.8 Configure the Internet Explorer for viewing locally published ART files 
Make the Internet Explorer (IE) the default browser for viewing locally published simulations, courses and 

websites. To be able to view the published ART content you need to make several changes in the IE settings 

using the steps below: 

1. Launch the Internet Explorer 

2. Select in the right-upper corner the wheel (tools)  
 

3. Select Internet Options Advanced 
 

4. Scroll down to the Security Section and enable also the following option: 
   “Allow active content to run in files on my Computer” 
 

 
5.    “Click the OK button 
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2.1 Configure Google Chrome for viewing locally published ART files 
Best practice is to use the Internet Explorer for viewing locally published ART HTML files (see previous 

paragraph). When you somehow have to use the more secure Chrome browser you need to include an Add-

in which allows viewing HTML files locally. Here are for example two possible Add-in’s you could use:  

https://chrome.google.com/webstore/detail/local-explorer-file-manag/eokekhgpaakbkfkmjjcbffibkencdfkl 

https://chrome.google.com/webstore/detail/enable-local-file-

links/nikfmfgobenbhmocjaaboihbeocackld/related 

 

2.2 Configure FireFox for viewing locally published ART files 
Best practice is to use the Internet Explorer for viewing locally published ART HTML files (see previous 

paragraph). When you somehow have to use FireFox browser you need to perform the following steps: 

1. Open new Firefox tab. 
2. In the URL enter:  about: config 
3. Click "I accept the risk" button 
4. Locate "privacy.file_unique_origin" (BY default is set to TRUE) 
5. Right-click and select Toggle, value should become FALSE. 
6. Launch the course/simulation again 
 

2.3 Configure Edge for viewing locally published ART files 
Best practice is to use the Internet Explorer for viewing locally published ART HTML files (see previous 

paragraph). When you somehow have to use Edge browser you need to perform the following steps: 

 

1. Close Microsoft Edge. 
2. Make note of the location of the Microsoft Edge (msedge.exe) application.  
3. Locate the Microsoft Edge shortcut on your desktop or in your Start menu. 
4. Right click on the shortcut. 
5. Select Properties. 
6. Select and copy the data in the Target field on the Shortcut tab. 
7. Paste the data into a new text file. 
8. Remove the msedge.exe from the end of the text. 
9. Click the Windows Start button. 
10. Type cmd in the Search field.  
11. Press the Enter key to start a command prompt and select Run as Administrator. 
12. In the command prompt type: 

cd <Microsoft Edge application path> 
Example: cd C:\Program Files (x86)\Microsoft\Edge\Application\ 

13. Press the Enter key. 
14. In the command prompt type: msedge -allow-file-access-from-files 
15. Press the Enter key. 
16. Microsoft Edge will launch, and will now be able to display uPerform content locally. 

Note: The course must be opened in this browser window that was launched via the command prompt. 
17. In the URL field, use the path to the index.htm file of the locally published simulation or course 

Examples:  
C:\Users\[username]\Documents\Course_Name\course\html\index.htm  
C:\Users\[username]\Documents\Document_Name\sim\html\index.htm 

 

https://chrome.google.com/webstore/detail/local-explorer-file-manag/eokekhgpaakbkfkmjjcbffibkencdfkl
https://chrome.google.com/webstore/detail/enable-local-file-links/nikfmfgobenbhmocjaaboihbeocackld/related
https://chrome.google.com/webstore/detail/enable-local-file-links/nikfmfgobenbhmocjaaboihbeocackld/related
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2.4 Get warnings on steps with too much text 
Best practice is to ensure you get to see warnings in the steps that have too much text. Use the 

File>Preferences editor to set the correct Filters to be able to see these warnings. 
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2.5 Adjust your Display Scaling to 100% 
To ensure the red arrow pointers in the auto-generated screenshots published in the Job-Aid documents will 

be placed correctly, you need to set your monitor display scaling to 100%. Right-click on your main desktop 

and select Display Settings. Below an example: 

  

  

 

2.6 Recorder Tuning Options 
The recorder tuning option allows you to specify how you want the recorder to handle certain actions during 

the recording process. These options are useful for when you want to record supported target applications, 

as well as record unknown and inaccessible controls.  
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2.7 Recording on Java applications 

Note: You can skip this section when you are not planning to record on Java Applications. 

When you first record a Java application, the ART Recorder will detect if Java Access Bridge (JAB) has been 

configured appropriately for the Java application being recorded. If the application detects that JAB has not 

configured properly, a message appears advising that JAB needs to be configured for the Java Runtime 

Environment (JRE). The message may be similar to: "For best results recording this application, configure 

Java Access Bridge into this Java Runtime Environment." 

 

Enabling Java Access Bridge with Administrator Permission on your PC 

1. Browse to the application's installation folder. 

C:\Program Files (x86)\Adoption Readiness Tool 

2. Double-click the file: jinitcfg.exe 

3. Click Next. 

4. Select the Java Runtime Environment used to run the Java application and the corresponding JAB 

version. If the JRE path you need to configure is not listed, you may also manually locate the JRE (if it 

is in a self-contained application) by clicking the Browse button. 

5. Select Always replace existing files. 

6. Click Next. 

7. Click Next. 

8. Click Finish after the configuration is complete. 

9. Start the ART recording process again. 
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Enabling Java Access Bridge using Jabswitch during Recording without Administrator Permission 

Beginning with version 5.4, JRE 1.7_06, is shipped with JRE and provides the jabswitch tool to enable and 

disable Java Access Bridge (JAB). Jabswitch allows an author in certain circumstances to enable or disable 

JAB without administrator permission. The Jabswitch process only works with JRE 17.06 or higher.  

1. When you first record a Java application, the Recorder will detect if JAB has not been properly 
configured and the following message appears: "For the best recording results, Java Access 
Bridge needs to be configured into JREs on the system. Do you want to stop recording and 
proceed with the configuration?" 

2. Click Yes 

3. The Recorder stops and the document and all the steps recorded up until this point opens in the 
Editor. 

4. After the JAB has been enabled, a screen appears stating: "Java Access Bridge configuration is 
complete. For best recording results, please close and re-open the following applications." 

5. This message lists all the Java applications running when you clicked the "Yes" button in Step 2.  

6. Click OK. You will have to close the applications manually. This window can also be closed by 
clicking the "X" in the upper-right corner. 

7. Click OK 

8. Perform one of the following: 

If Then 

The application is currently run as an 
administrator or if the current user is in an 
administrator group 

1. JAB will update automatically 

in the background. 

 
2. Continue editing or recording. 

The current user is in an administrator group, 
but User Account Control setting is set to 
"Default" or "Always notify" 

1. Go to Step 9. 

The current user is not in an administrator group, 
" 

1. Go to Step 11. 

 

9. Click Yes to the User Account Control message so the application can make changes to your PC. 

10. After the changes are made, you can continue editing. 

11. Enter the administrator password in the User Account Control  window, Click Yes. 
 

Note: If "No" is clicked in Step 9 or Step 12, recording will resume, but the next action on the Java 

application will be captured incorrectly. The message asking a user if they want to stop recording and 

configure JAB will not appear again unless the user stops the recording and re-creates it. 

 

 

https://uperformhelp.ancile.com/hc/en-us/articles/Step9
https://uperformhelp.ancile.com/hc/en-us/articles/Step11
https://uperformhelp.ancile.com/hc/en-us/articles/Step9
https://uperformhelp.ancile.com/hc/en-us/articles/Step12
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2.8 Recording on applications in a Virtual Remote Lab environment 
To ensure that the ART recorder will capture the right properties of the buttons and fields that you are 

clicking on during a recording of a step-by-step process on an application that is running inside a remote 

virtual lab environment, you need to install ART within that virtual lab environment. 

When you try to record with the ART from your local PC on a remote virtual lab environment, ART will not be 

able to recognize the objects it’s clicking on and will not be able to create the correct  auto-generated action 

instructions.   

Authors can use ART client software from a 32-bit or 64-bit Terminal Server to support the generation of 

content. ART has been tested against Windows Terminal Services (2008) and Citrix XenApp™ (v4.5). We will 

support customers using newer versions of Citrix although they have not been tested. ART does not support 

application publishing, remote applications, or web gateways from a Terminal Server. The Citrix server 

technical specifications will vary depending on other applications in use on the Citrix server, as well as the 

number of planned concurrent ART authors. 

All target applications to be recorded with ART must also be installed on the Citrix instance. You cannot use 

ART installed on Citrix to record an application installed on the local computer. Also you cannot use ART 

installed on your local PC to record an application on the Citrix instance. 
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2.8.1  Setting up the Resolution of the remote VM 
1.  First set your local PC system resolution to 1600 x 900. 
2.  From your local PC, open the Remote Desktop Properties and set the display to 1600 x 900. 
3. Connect now with RDP to the VM and you will see that the resolution of the desktop in the VM is 

automatically set to the same 1600 x 900 resolution 

 
 

2.8.2  Cleanup de VM desktop before recording 
1. Hide your Windows Task Bar:  

a. Right-mouse click on the task bar and select properties, as shown in the following screenshot. 

b. Select the Auto-hide the taskbar check box, as shown in the following screenshot. 

2. Hide browser toolbars that you do not need so that you have more room on the screen for the 
application. 

3.  If you need to hide the icons on your desktop, right-click on the desktop and select View -> Show 
desktop icons to disable the option. 
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2.9 Set your desktop screen resolution to 1600 x 900 
The default ART template is set to use a desktop resolution of 1600x900 so when you have selected a lower 

resolution on your desktop you will get an error at the start of your recording. Set your laptop/desktop 

display resolution to 1600 x 900. Regardless of how you connect to your environment, your desktop/laptop 

must be set to 1600 x 900 for recording. Even if you are using RDP to connect to the environment, you must 

still set your desktop resolution to 1600 x 900. 

 

2.10 Desktop settings before recording 
4. Hide your Windows Task Bar:  

a. Right-mouse click on the task bar and select properties, as shown in the following screenshot. 

b. Select the Auto-hide the taskbar check box, as shown in the following screenshot. 

5. Hide browser toolbars that you do not need so that you have more room on the screen for the 
application. 

6.  Its much better to clean-up your desktop before recording and hide icons you don’t need: 
to hide the icons on your desktop, right-click on the desktop and select View -> Show desktop icons to 
disable the option. 

7. Close any applications you do not need which could trigger notifications to pop-up during your 
recording. 

  



      INSTALLATION GUIDE | Adoption Readiness Tool - ART®  

 

Page 23 of 51                                           © Copyright 2022 – Micro Focus 

 

 

2.11 Add a PowerPoint slide screenshot in your step-by-step Recording 
You can also include one or more PowerPoint slides in your step-by-step recording. 

Just simply make a screenshot of your powerpoint and then paste that into the step of your choice.  

Below this process in some more details: 

1. Goto your target application, put it in full desktop screen mode and make a screenshot 
2. Goto the ART Editor where you see the steps from your recording (Simulation Tab) 
3. In the ART Editor select the step for which you want to change the screen capture 
4. Right click this step and copy it, now you still have the original step in case you need it later  
5. Right-click the step for which you want to replace the current screen  
6. Select Edit Step 
7. Select Screen 
8. Click the Paste button. The original screenshot is now replaced with a screenshot you’re your 

powerpoint 
9. Publish your recording and test the output 
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3 Uninstalling ART 
When your installation is not working properly after a PC migration for example you will need to remove all 

ART software components first and then re-install it. The next steps will describe how to perform this 

procedure. 

  

6. Uninstall the ART software through the windows configuration panel: Uninstall a 

program 

 
 

 

7. Uninstall the Capture Engine (if you have installed it earlier) through the windows 
configuration panel 
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8. Open the windows file explorer  

 
 

9. Navigate to folder  
C:\Users\<your name>\AppData\Roaming\Hewlett Packard Enterprise 
C:\Users\<your name>\AppData\Roaming\Micro Focus 
and remove any Adoption Readiness Tool (ART) related folders. If you installed both ART 
and ART ELE ensure to remove both folders from the roaming data folder. 
 

10. Navigate to folder C:\Users\<your name>\AppData\Roaming\  
and remove the Ancile folder  

 
11. Reboot your PC 

After the reboot you can start to install the ART software 
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4 New Features ART 5.40.6   
ART 5.40.6 was released mainly to remove the dependency on Flash. Please see the provided release notes 
for a list of all the defects that were fixed as part of this release.  

4.1 Publish a type action without publishing the Field Description Table   
When you have imported our default template as part of this installation procedure you need to check the 

setting of the  Hide Field Description Table . Ensure its enabled. 

 

  

Below examples with this feature enabled and disabled.  

Hide Field Description Table - enabled Hide Field Description Table - disabled 

 

 

 
After you made the above changes, close the template and save it  
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4.2 Make Document Properties required for authors 
Document properties are used to auto-generate the performance support website containing the courses 

and simulations you developed and published in a local website format which you can host on your intranet. 

ART can automatically publish the content of the web pages and navigation structure using the values set in 

the document properties of the individual ART simulations and course files. Therefore it’s important that 

those properties have a correct value. For example you can use the module property value to specify to 

which page the content belongs to and it’s therefore important that the authors who are creating the ART 

files will set that property value. With ART 5.40.2 you can now enable mandatory file properties using the 

steps below. 

1. Select File>Open>Template and select your 
template 
 

2. Select the Properties tab and select or 
create the document property 
 

3. Enable checkbox Visible 
Use this checkbox to make the property 
visible to authors in the 
Properties...window. 
 

4. Enable checkbox Required 
Use this checkbox to make the property 
required, so authors must complete it. This 
option is only available if the Visible 
checkbox is selected. 

 

 

 

After you made the above changes, close the template and save it  
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4.3 Publish a Procedure Table from a step-by-step recording   

 
When you have imported our default template as part of this installation procedure you will see that the 

new Procedure Table publication type has already been enabled in the template Publications tab. Below a 

sample of a published Procedure Table.  

 

When you have not imported our default template as part of this installation procedure but imported your 

own customized template in the new ART 5.40, you can enable the new feature manually using the steps 

below. 

5. Select File>Open>Template and 
select your template 

6. Select Publications 

7. Enable the checkbox on the right-
hand side:  
Procedure Table 

 

 

 

After you made the above changes, close the template and save it. 
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4.4 Publish an MP4 video from a step-by-step recording   
With ART you can publish a step-by-step recording as an MP4 video. Here is an example of an MP4 video 
published with ART from a step-by-step recording where the process is starting with a few introduction steps 
which were recorded from a PowerPoint in presentation mode. With ART additional voice narration was 
recorded for each step.  
https://youtu.be/WEbkZT8Y_Gg 
 
Here is a sample MP4 video where additional Text To Speech was included after the template was 
configured to publish the Show-Me simulation with Text To Speech  
https://youtu.be/cbJKDmKdg60 
 
The default template step-by-step recording resolution for producing simulations, job-aids and MP4 video’s 
is set to 1600x900 and the ART recorder will give you a warning if your PC monitor display resolution is 
different.  
You can decide to record on a different 16:9 resolution like for example 1280x720 or 1408x792 for larger 

fonts and better readability. If you do so just ignore the warning ART will give you at the beginning of a new 

recording and check in the editor that the quality of the screenshots is OK. 

The template has been configured with a resolution of 1280x720 for the MP4 video’s that will be produced. 

This is a very common 16:9 resolution for MP4 video’s and also Youtube video’s.  

 

  

https://youtu.be/WEbkZT8Y_Gg
https://youtu.be/cbJKDmKdg60
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When you have not imported our default template as part of this installation procedure but imported your 

own customized template in the new ART 5.40, you can enable and configure the new MP4 Video feature 

manually using the steps below. 

1. Select File>Open>Template and 
select your template 

2. Select Publications tab 

3. Enable the checkbox on the right-
hand side: Video 

 

 

4. Select Publications tab 
5. Select Video in the left menu 
6. Select MP4 in the Video Output 

Format 
7. Select 30 Fames per Second. This 

is the rate at which an imaging 
device displays consecutive 
images called frames. In general, 
the minimum FPS needed to 
avoid jerky motion is 30. 

8. In the Video Dimensions select 
Aspect Ratio 16:9 and select  
resolution 1280x720 
 
Alternatively you can select the 
bottom radio button under Video 
Dimensions to use the same 
Simulation resolution as for the 
step-by-step recordings.  
 

 

 

After you made the above changes, close the template and save it. 
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5 Known Issues  
 

5.1 Publishing Errors 
In some cases you will see one or more publishing errors in the publishing summary for some of the output 

publishing types you have selected. The main root cause for this is that you still have one or more published 

documents open and that results in ART not being able to overwrite these files/documents with a new 

version. The best practice is to always close any generated output before you try to (re)publish. 

 

5.2 Using Pictures in Courses – Error: filename too long 
When you receive publication errors for a course mentioning that a filename is too long, it means that there 

are issues with the pictures that you included in the course file. These pictures probably came from a 

location deep down in your folder system. This causes errors when publishing.  

The best practice is too create an images folder close to the root folder of your PC, copy any pictures or 

movies you want to use first to this new folder and then import with ART the picture/movie from that new 

images folder. 

 

5.3 Importing PowerPoint slides in a Course 
When importing a PowerPoint with various slides into an ART course, ensure you select the individual check-

boxes for those slides you want to import as visible in the screenshot below. The default way of importing 

slides is to import them as an image. 
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5.4 Filename conventions 
Naming conventions are a great way for naming your files in a way that describes what they contain and how 

they relate to other files. But be careful that you don’t go overboard when naming ART files because this 

could cause a local publishing failure. The fully qualified file name must be less than 260 characters, and the 

directory/outbox name must be less than 248 characters. 

 

We recommend to keep the ART filenames as short as possible using the structure below:  

<ModuleNumber>_<AbbrevationofCourseName><version>.xxx 

<ModuleNumber>_<AbbrevationForNameofTask><version>.xxx 

 

1. Abbreviate the file names 

2. Do not use any spaces 

3. Add the module number as a 2-digit number in front of all file names 

4. Use an underscore character between words  

5. Keep a course and the corresponding recordings in one folder together.  

An example: 
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5.5 Uploading files in the resources/downloads area 
Please ensure all files have a unique physical file name before you start uploading them into the Resources 

folder. Also the physical file name should not include any special characters.   

 

 

 

 

 

5.6 Icon’s in information notes not displayed correctly 
Sometimes the icons on the information notes are not getting displayed. This workaround should fix it. 

 

Workaround 

1. Open the simulation and save it to the same folder as where you saved your course 
2. Publish your simulation locally to a default output folder 
3. Open the Course and save it to the same folder as where you saved your simulation 
4. Navigate to the page with the simulation 
5. Click Edit Simulation Properties 
6. Select 'Insert' from the insert dropdown list 
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7. Select the simulation that you saved a minute ago 
8. Select the mode visibility check boxes at the right side to include the right types of simulations for 

your course page 
9. Click Insert button 
10. Republish the Course and test 
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5.7 YouTube movie in course page not visible 
After copying the embedded code from a YouTube movie into the ART video properties page the video won’t 

be visible in the preview and also not in the published course. 

Workaround 

Let’s take for example the following YouTube movie: 

https://youtu.be/7d70SbswKqI?list=PL92KZZ3tyNdME1Gs4AHsL4nzQRqbzU7A0 

When you right-click and copy the embedded code into the video properties page in ART you will get to see 

the following code: 

<iframe width="640" height="360" 

src="https://www.youtube.com/embed/7d70SbswKqI?list=PL92KZZ3tyNdME1Gs4AHsL4nzQRqbzU7A0" 

frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-

picture" allowfullscreen></iframe> 

You must remove the red colored text to ensure the last part will look like: 

allow="autoplay"></iframe> 

It will then look like in the screenshot below and will make your video visible in both preview and published 

course page. 

 
 

  

https://youtu.be/7d70SbswKqI?list=PL92KZZ3tyNdME1Gs4AHsL4nzQRqbzU7A0
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5.8 Hot Spots publishing issue 
Ensure you do not add any special characters inside the Hot Spot text otherwise it will trigger a publication 

error.  

 

5.9 Hot Spots at the top of a course page are not working correctly 
When your skin.css file is configured wrongly it can happen that any hotspot at the very top of an image in a 

course page will have areas where it does not respond with the mouse hover over pop-up configured to 

show the pop-up window. This issue can happen with the new ART 5.40.2 but not with the new ART ELE 

5.40.2  

Workaround 

Move any hot spots in a course page which are sitting in the top of the screen to the area a little bit lower 

until they start behaving normally (approximately one centimeter). Here is also a video demonstrating the 

issue and the workaround: 

https://youtu.be/-2b_C34Z2Yc  

Hots Spots in a course that are affected and not properly working (at the top of the page) 

 

 

Hot spots after the correction (moved down one centimeter) 

 

 

  

https://youtu.be/-2b_C34Z2Yc


      INSTALLATION GUIDE | Adoption Readiness Tool - ART®  

 

Page 37 of 51                                           © Copyright 2022 – Micro Focus 

 

The issue can be fixed by increasing the top parameter of the UI section in the skin.css file  

that you can find at: 
C:\Users\<your name>\AppData\Roaming\Micro Focus\Adoption Readiness 

Tool\version 5.40\skins\Course\custom\ADFIAP ART 5-4-Rounded\skin 

 

Open the file with notepad and locate the top parameter in the UI part, increase the value with 10  and re-

publish your course to validate the hotspots. When it is still an issue, repeat the above step until the 

hotspots at the top of the image are working properly. 

 

Recommendation 

When upgrading existing courses or creating new courses with the newer version of ART, Check the 

functionality of each hot spot in every course page and adjust those that are not working properly. 
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5.10 Guided Help can be found under Copyright in the publishing summary 
After upgrading to the latest ART 5.40 you will find published Guided Help under the item Copyright in the 

Publishing Summary dialog. The guided help itself is automatically embedded into the published simulation 

GUI so you actually do not need to worry about it unless you want to use it somewhere standalone. 

 

 

5.11 Quick Reference Flow is not being published correctly 
After upgrading to the latest ART 5.40 the Quick Reference Flow is not published correctly for a step-by-step 

recording. We have no workaround for this currently.  

 

5.12 New text values from the dummy links in ART website not published   
After changing the text inside the properties from the  Product Home Page dummy link and the Course Page 

dummy link, the re-published ART website still shows the old text values. 

Workaround: 

1. In the ART website file make the changes to the text values in the properties of the dummy links: 
Product Home Page dummy link and the Course Page dummy link 

2. Save the Website file 
3. Stop ART  
4. Start ART  
5. Re-Open the ART website file 
6. Re-Publish the website  
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5.13 New Copyright text value not published after upgrading an ART Website file  
After upgrading the template and changing the copyright text (template>properties>copyright),  

the old copyright text is still being published in ART websites.  

 

In the screenshot below you see the new copyright value. 

 
 

When publishing an ART website it is still using the old copyright value 

 

Workaround: 

1. Open the Windows File Explorer 
2. Navigate to C:\Users\<your name>\AppData\Roaming\Micro Focus\Adoption Readiness Tool\version 

5.40\unpacked\templates\67CDC75B\data 
3. Open with Notepad++ the file  phrases.xml 
4. Manually change all the lines that contain the Copyright text value  
5. Save the file 
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6 Upgrading your customized template and known issues 
When you decide not to use our default ART template and skin that we provided as part of this ART 5.40 

installation and want to upgrade your existing template instead, you will encounter various issues when 

publishing your simulations and courses. When opening your existing template with the new ART 5.40 it gets 

automatically upgraded and in that automatic upgrade process some of your settings might get lost and set 

back to default. This chapter you will find several examples and the corresponding workarounds.  

Your custom course and simulation skin folders including the settings ART template will stay in place when 
you import your existing template and skin. However, new versions of ART can include new course or 
simulation interface functionality which corresponds to additional code in the skin CSS files and they might 
need to be updated in order to take advantage of this functionality and avoid errors.  To make sure you are 
using the most up to date skin code along with your customizations, please follow the guidelines below. 

1. Always document any customizations you make in case you need to redo them after an upgrade. 

2. Check the Release Notes for your new ART version to see if any changes have been made to the 
default course or simulation skin files.  
 

3. Check the CSS changes for the default skin you originally used as a starting point for your custom 
skin.  Depending on the changes, and how many customizations you have made to your custom skin 
files, do one of the following: 
 

o Incorporate the new and changed styles from the default skin into your custom skin. 
 

o Recreate your custom course or simulation skin based on one of the default skins 
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6.1 Template is not configured to use the custom skin  
After upgrading the template and your custom skin, the template uses the default skin instead for publishing 

the courses.  

Workaround 

1. Open the template and select the Publications tab 
2. Select Course from the Default Publication Settings 
3. Select Course User Interface Settings from the top right corner list box 
4. Select your custom skin in the Skins section 
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6.2 Text Hyperlink invisible in course pages with white background  
After upgrading the template and publishing a course, the hyperlinks inside the text of a course page 

becomes unreadable as they are white text and in the white background they are un-readable in the course 

text pages.   

Workaround 

1. Open the template and select the Publications tab 
2. Select course from the Default Publication Settings 
3. Select Course User Interface Settings from the top right corner list box 
4. Scroll down to the section Text Colors  
5. Change the Link Text Color from White to Blue 
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6.3 Simulation hyperlinks are hard to read on the simulation launch page  
After importing your 5.30.6 Template and Skin into the new ART 5.40.2 you will have to redo your 
customizations like for example the color of the hyperlink for both the course and simulation launch/splash 
pages through the template.  

Simulation Launch Screen General tab>Data Files>simulation_index.htm 

Course Launch Screen General tab>Data Files>Course_index.htm 

 

Here is an example on how you can change the colors for the hyperlinks in the simulation launch page in the 

simulation_index.htm 

 

1. Open your template and navigate to General tab>Data Files>simulation_index.htm.  
2. Click Modify. The file opens in an editor such as Notepad.  
3. Scroll down to the </script> tag.  
4. After this tag you can see a section with the URL color codes for the URL’s.  
5. It starts with a:link, a:active, a:visited and there is another section below it starting with: a:hover 
6. The color codes use hexadecimal strings to specify color in HTML files.  

For example, the hex value for white is #FFFFFF and for black is #000000. 
7. Click File>Save and Close the HTML editor. 
8. Check that you changes have been applied and open the file again via the steps above and close it  
9. Save the template and close it 
10. Re-open the step-by-step recording in the editor and re-publish the simulations. 
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6.4 Course hyperlink is hard to read on the course launch page  
After importing your 5.30.6 Template and Skin into the new ART 5.40.2 you will have to redo your 
customizations like for example the color of the hyperlink for both the course and simulation launch/splash 
pages through the template.  

Simulation Launch Screen General tab>Data Files>simulation_index.htm 

Course Launch Screen General tab>Data Files>Course_index.htm 

 

Here is an example on how you can change the colors for the hyperlinks in the course launch page in the 

course_index.htm 

Workaround 

1. Open your template and navigate to General tab>Data Files>course_index.htm.  
2. Click Modify. The file opens in an editor such as Notepad.  
3. Scroll down to the </script> tag.  
4. After this tag you can see a section with the URL color codes for the URL’s.  
5. It starts with a:link, a:active, a:visited and there is another section below it starting with: a:hover 
6. The color codes use hexadecimal strings to specify color in HTML files.  

For example, the hex value for white is #FFFFFF and for black is #000000. 
7. Click File>Save and Close the HTML editor. 
8. Check that you changes have been applied and open the file again via the steps above and close it  
9. Save the template and close it 
10. Re-open the step-by-step recording in the editor and re-publish the course  
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6.5 Invisible action boxes around the field or button in a simulation 
After upgrading the template and publishing a simulation, the red colored action boxes have become 

invisible as the color is now transparent. 

 

Workaround 

1. Open your template and navigate to Publications> Default Publications Settings> Simulation  
2. Select from the list box on the top right: Simulation general Settings 
3. Scroll down in the right panel to the section: Action Defaults. 

 

   
4. Change the Action Border Color from Transparent to Red. 
5. Save the template and Close it 
6. Re-open the step-by-step recording in the editor and re-publish the simulations. 
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6.6 Re-apply the customizations for the rounded Skin 
When you decide not to use our default rounded skin that we provided as part of this ART 5.40 installation 

and want to upgrade your existing rounded skin instead, you will need to re-apply your specific 

customizations to this skin. 

The Course Player colors control things like the course banner background color, navigation button 
background or text colors, or Progress Bar background colors.  Colors for the default course skins (Default - 
Logo Left, Default - Logo Right) Player Colors are controlled in the template under: 
Publications -> Default Publication Settings -> Course -> Course User Interface Settings dropdown -> Player 
Colors 

Course Player Colors for the non-default or custom course skins are controlled via code modifications to the 
Skin.css and Content.css located in the custom skin folder which you can find in the folder: 
C:\Users\<your name>\AppData\Roaming\Micro Focus\Adoption Readiness Tool\version 
5.40\skins\Course\custom\<name of your rounded skin>\skin 
 
The course styles listed in the table below are found in the template under the Styles section.  Each style is 
numbered in this table, and referenced by number in the images to illustrate which style affects which 
element in the published course. 
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Template Style Description 

1. Default Course Title Text The style to be used for the text displayed as the course title. 

2. Default Course Page Title Text The style to be used for the text displayed as the page title in a 
course. 

3. Default Course Content Title 
Text 

The style to be used for the text displayed in the content title area 
of a course. 

4. Default Course Popup Text The style to be used for the text displayed as a popup in a course. 

5. Default Course Text The style to be used for the course text that’s not associated with 
another style. 

6. Default Course Drag Drop Text The style to be used for the text displayed for drag and drop in a 
course. This applies to answer text on pages created using the 
“Drag and Drop”, “Drag and Drop – Many to One”, and “Drag and 
Drop – Sequencing” stencils. 

7. Default Course Questions Text The style to be used for the text displayed as assessment or 
knowledge check questions in a course. 
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7 Samples of online training with multi-media content created with ART 
 

Samples of online training created and published with ART as a performance support Web Site 
www.microfocus.com/software/artsamples 

MP4 video samples published with ART from a step-by-step recording  
Sample MP4 created with ART 5.40 Beta incl Voice Narration: https://youtu.be/WEbkZT8Y_Gg 
Sample MP4 created with ART 5.40 Beta incl Text To Speech (TTS): https://youtu.be/cbJKDmKdg60  
Note: the videos have been produced using only ART! 

Sample NSOL video – Data Protector 
https://www.youtube.com/watch?v=-CIE_fLnKbg 
Note: the videos have been produced using ART and Camtasia 

Sample NSOL video – ALM-UFT Integration 
https://youtu.be/YRmSpT47OCI  
Note: the videos have been produced using ART and Camtasia 

 

 

  

http://www.microfocus.com/software/artsamples
https://youtu.be/WEbkZT8Y_Gg
https://youtu.be/cbJKDmKdg60
https://www.youtube.com/watch?v=-CIE_fLnKbg
https://youtu.be/YRmSpT47OCI
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8 Training Information 
Do you need someone to demonstrate ART for you department? Request an ART expert via:  

ART-Demo@microfocus.com 

 

Online Training for Free! 

The online Get Started with ART training covers the step-by-step installation process, shows how to Record 

and Publish a step by step process and teaches you how to create and publish a training course. You can 

launch it from our ART Product page www.microfocus.com/software/art 

 

Quick Reference Guide  

From the downloads section you can find the Quick Reference Guides for ART, which includes the most 

common tasks performed with ART such as doing recordings, publish as simulations, publish as  and job-aids 

and creating course modules.  

 

Local Help Files 

As part of the installation process you have been unzipping the local help files and created a favorite in the 

Internet Explorer. These help files are a good starting point for more information on the ART solution and 

product manuals.  

 

Online Community Support 

www.microfocus.com/software/art/art54/onlinesupport 

 

Further enablement on the ART solution 

Micro Focus provides both onsite and remote enablement on the ART solution which are listed at the 

bottom of our ART landing page. For more detailed information contact your local Micro Focus ITOM 

Software Education department at: www.MicroFocus.com/Training 

From there navigate to the Contacts tab 

 

 

 

 

mailto:ART-Demo@microfocus.com
http://www.microfocus.com/software/art
http://www.microfocus.com/software/art/art54/onlinesupport
http://www.microfocus.com/Training
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9 Getting Support  
Are you new to ART? Checkout our Product Homepage first to learn more about ART and ART Enterprise 

Learning Edition: www.microfocus.com/software/art 

 

On the Micro Focus Software Support Portal  https://mysupport.microfocus.com  

you can find various options to get support like the knowledge base,  

support forums, submit a service request and a live chat with a support agent.  

The following URL provides you the latest Customer Support Handbook 

For receiving personal assistance for creating a new service request  

we kindly ask you to contact one of our agents as listed in the following document:  

https://softwaresupport.softwaregrp.com/doc/KM00006 

 

 

  

http://www.microfocus.com/software/art
https://mysupport.microfocus.com/
https://www.microfocus.com/media/guide/micro_focus_software_support_guide.pdf
https://softwaresupport.softwaregrp.com/doc/KM00006
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Additional Support Information 

 

1. Business Support Agreement  
2. Premium Support  

 

Online Technical Support 

The online technical ART support team as a web portal that can be accessed through the following URL  

www.microfocus.com/software/art/art54/onlinesupport 

Do you need someone to demonstrate ART for your department? Request an ART expert via:  
ART-Demo@microfocus.com 
 

 

 

https://www.microfocus.com/support-and-services/maintenance-and-support-agreements/
https://www.microfocus.com/en-us/services/premium-support
http://www.microfocus.com/software/art/art54/onlinesupport
mailto:ART-Demo@microfocus.com

